Re: Card and MIDI Files list discussion......

[ Follow Ups ] [ Post Message ] [ The QuadraSynth Forum ] [ FAQ ]

Posted by Rick on September 19, 1997 at 08:13:25:

In Reply to: Having trouble loading midi files into my QS7 posted by Tom Niemi on September 18, 1997 at 13:17:23:

Hi Tom ....
Hopefully some of the following will help.

Let me guess: You are using Cakewalk.
OK, here is an important fact for people who can’t seem to use Sequences on Flash-Cards:
We are looking into the problem. Cakewalk writes SMFs in some slightly non-standard way, giving you strange patch changes. I have had the same problem. Here is what I do to fix it. You just have to load it into another program (like Cubasis) and save it again. Then it works just fine.
We are working with Cakewalk to identify and fix the problem.

Boris Wiedenfeld

Alesis Synthesis
Just wanted to report that the sequences that I generated in Cakewalk
3.01 did work after importing then exporting them out of Cubasis.

Unfortunately, using the old CAKE2MID function did not work. (Wouldn’t even load in the QSR.) It’s unfortunate that I need to keep this additional sequencer around just to fix my MID’s.
I think I asked this before, but does anyone have a definitive answer whether Cakewalk 6.0 will output midi files which will work on the QS7/8/R?
I also would like to correct something that I said previously:
BTW, the drum mappings from the Alesis DM5 is NOT the same as the

drum mapping on the QSR DM5 Drums program. This bites since I do
all my sequencing using the real DM5, but I want to be able to
simply change the sequence to use the QSR rather than the DM5. (I
don’t see any reason why this had to be done.) I guess I’ll have
to create a new drum program that mimics the real DM5 mappings,
unless Alesis wants to do it for me (hint, hint, nudge, nudge,
wink, wink, say no more, eh?)

It appears that the two mappings are the same (as best as I can tell within the limitations of the QSR.) What I was hearing was the the DM5 Drums program on the QSR uses a velocity triggered sample on the snare, so when the snare was hit softer during the fast fills, I was hearing rim shots instead of the snare I expected. It looks like there are plenty of drum programs on the CD which do not use the velocity triggered samples, so Alesis did do what I asked for in the last part of my message. Just didn’t want anyone to have the wrong information.


Pat Waara

I had as much trouble with type 1 SMF (.mid) files from Pro Audio 6.0, as I did with my CW Homestudio 3.0 .mid files. However, after saving the files as type 0 SMF .mid files in Pro Audio 6.0 they transfer beautifully from my 486 PC/Soundbridge to the Flash RAM in my QS 8. I now have 9 flawless sequences on my card.
Stein A Rimehaug
Hi List.
Inspired by Stein’s results (thanks again) I have done some research in the sequence / FlashRAM issue and came to this bold conclusion:
When using sequences with Soundbridge 1.2 for Windows, YOU SHOULD USE SMF TYPE 0 FILES. IT IS NOT RECOMMENDED TO USE SMF TYPE 1 FILES.
Besides the fact that using type 0 will fix the ‘Cakewalk Bug’, I have noticed that the examination and conversion of a type 0 file takes less than one tenth the time required for a type 1.
So, ignore all contradictory info you might have heard from us in the past, this is the new info... :)
Happy sequencing,

Boris Wiedenfeld

Alesis Corporation

PS: If you really want to use type 1 and you are NOT using Cakewalk, you may certainly do so. However the compilation will take significantly longer.
Coincidentally, I was just going to make this same report today. Last night I experimented with exporting sequences from Cakewalk 3.01 as type 0 mid files, and yes indeed it did work. This saves me the hassle of having an additional sequencer around to convert the Cakewalk mids.
On 18 Aug 97 Jeff Fried (Volt Computer) had this to say about RE:
You are right in that only Type 0 MIDI files can be stored regardless of
the sequencer. (at least in my experience). I’ve also found that TYPE 0
Cakewalk MIDI files don’t seem to work.

I used a very simple sequence in my experiment (bass on channel 1 and drums on channel 10--several tracks), exporting from Cakewalk 3.01 as type 0, and also a kind soul from the Cakewalk list sent me the file exported from Cakewalk 5.0 as type 0. Both sequences worked. I’m not sure why yours aren’t working. Have your tried running the type 0 sequences from Cakewalk driving your QS? Maybe there’s something inherent in your sequence that type 0 mids can’t handle.
Pat Waara

: Hi,
: I have had a QS7 for about 4 months now and am just starting to load *.mid files using Soundbridge. Sequences work great when I am using Cakewalk Pro 2.0 for windows. But when I try to load them into the synth, either as files stored from CW as midi files or as midi files down loaded from the net, only about 10% of my loaded sequences work correctly with the correct patches. Most of the time I will get other patches selected, or notes will hang up, or it will be detuned, and often the drum lines will not be correct and another patch will be assigned to the drum track.

: I talked to the Alesis rep and he suggested that CW was altering the files a little, even though they were stored as *.mid files, so I tried loading midi files that had not be previously processed by CW. No difference.

: Has anyone run across this problem, and if so, what did you do to fix it?

: Thanks - Tom Niemi

Follow Ups: